Disable Vulnerabilities Check in FreeBSD Portupgrade

After perform FreeBSD portsnap, there are updates for PHP52 packages, but when I run portupgrade -vr php52*, it stopped and displayed portaudit error messages regarding php52 has vulnerabilities.

Which is weird to me because isn’t that the updates are suppose to fix the vulnerabilities?

To overcome the error building/upgrade the port, invoke the make argument by allowing the portupgrade


# portupgrade -vr -m DISABLE_VULNERABILITIES=yes php52* 

This will ignore the vulnerabilities error message and continue with portupgrade of php52 packages. It can be use for other ports upgrade when you see the vulnerability error messages.

Leave a Reply